Hello there, is this your first visit?
Register

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11
    Join Date
    Jan 2018
    Location
    Cypress, TX
    Posts
    12
    I'm pretty sure I have the trans selected correctly but will def double check

    The part that has me thinking is it seems like the configuration of the transmission is suspect. I bought the 4R70W and controller out of a local guys car when he wrecked it. The factory tag on the transmission looks to show its out of a 2003 3.8 Mustang, it has an analog range selector and the older style speed sensor on it. I figured it would be a digital selector and the larger square speed sensor being a 2004 trans……

    Tag = 3R3P-7000-CA-ECTO
    Last edited by MBR; 06-09-2018 at 03:28 PM.

  2. #12
    Join Date
    Apr 2006
    Location
    KCMO
    Posts
    9,116
    If the range sensor is the oval connector, that is not 98+ range sensor anyway.
    If the connector on the passenger side is WHITE sticking up out of the trans, that is not 98+ internal wires
    TOS sensor on the rear of trans case can be either - same function.

    Pull the sensor and see if it is reading 6 holes, or 24 lugs.

  3. #13
    Join Date
    Jan 2018
    Location
    Cypress, TX
    Posts
    12
    Yea after talking to Rick @ US Shift on Friday he was able to pin point the issue after I told him my concerns of the trans. Come to find out at some point in its life it's an 03 trans with the older connectors, solenoid, etc. I just wish it had a gear inside for a mechanical speedo, now I need to figure out a way to get my speedometer to work.

    Rick basically said the trans needed the speed sensor input changed to the newer 24 pulse and it fixed all the issues I was having, car pulls like a beast on the freeway

  4. #14
    Join Date
    Apr 2006
    Location
    KCMO
    Posts
    9,116
    So like I was thinking....the TOS was reading 24 and not 6.
    But it is a bastard trans for sure if you have old electronics, it is a 2003, and the 24 count ring gear was not released until mid 04 - so - welcome to the world of hodge podge transmission repair.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •